Keyboard Shortcuts

Mac OS X users: In windowed mode, F12 and F11 may be intercepted by the desktop, so you may need to combine them with the Cmd key, for instance Cmd+F12 to toggle menu mode. With a laptop, you may even need to combine this with the Fn key, depending on your setup.

  • F12 – Enter/exit menu mode. See notes for laptop and Mac OS X users below.
  • F12 + QQuit the emulator.
  • F12 + GRelease/capture mouse and keyboard input grab. Clicking the middle moue button will also release input grab.
  • F12 + F – Toggle full-screen mode.
  • F12 + Z or F11 – Cycle through zoom modes.
  • F12 + B – Toggle border display, zooming out a little bit to reveal more of the display.
  • F12 + S or Print Scrn – Save a screenshot of the current Amiga frame to the desktop.
  • F12 + R – Soft reset.
  • F12 + THard reset.
  • F12 + AFreeze button for use with Action Replay.
  • F12 + D – Activate debugger (console only).
  • F12 + M to mute the sound.
  • F12 + W to toggle warp mode (no frame limit, no audio). This does not affect the emulation accuracy, it only removes the pauses between generating frames.
  • F12 + Comma to decrease the volume.
  • F12 + Period to increase the volume.
  • F12 + P or Pause/Break key to pause the emulation.

Laptop users: Depending on your laptop, you may need to combine the above keyboard shortcuts with the Fn key, or toggle the F-Lock key first. Worst case is Mac laptop where you may need to press Fn+Cmd+Key.

For all shortcuts where F12 is combined with another key, you can also use F11 instead. Example: F11+Q will also quit the emulator.

Emulating a Joystick or Gamepad via the Keyboard

See Keyboard Input.

Additional Shortcuts

The following shortcuts work, but you should be aware that the Alt key press will be sent to the emulated Amiga before you have completed the shortcut combination, so the key press may have side effects on the emulated Amiga:

  • Alt+Tab (or Cmd+Tab) – Switch to another window / release input grab.
  • Alt+F4 – Quit the emulator.
  • Alt+Enter (or Cmd+Enter) – Toggle fullscreen mode.
  • Ctrl+F10 – Toggle performance graphs / FPS display (There are two FPS numbers shown, SYS: actual video output frame rate. EMU: emulated video frame rate).

Additional Shortcuts in Net Play Mode

The following shortcuts will only have an special effect while in net play mode:

  • Tab – toggle chat function.

62 thoughts on “Keyboard Shortcuts

  1. Will the F12+comma & F12-Period to increase/decrease volume work on an “application level only” or would this adjust the Mac’s main volume, which will affect all recording apps ?

    • Hi, the volume shortcuts in FS-UAE only affects FS-UAE’s internal volume levels. The system volume levels are unaffected!

  2. I got slight problem with triggering the shortcuts on OS X 10.10.5 on a Mac Book Pro. I’ve disable all F12 shortcuts, enabled that F-keys act as normal keys, and not the function keys.
    However, FS-UAE only prints the keycode to the terminal and does nothing else: ^[[24~d to show the debugger. I’ve also switched to a different keyboard layout (I’m using a custom layout), but it doesn’t help.

    • It sounds like you are using the key combination while the terminal is in focus (?). The FS-UAE window need to be the active window while you use FS-UAE shortcuts.

  3. Using Mac with OS X 10.10.3 I have no fire button (neither Right-Alt nor Right-Crtl work) with keyboard for joystick! Any ideas?

    • Hi, some possibilities:
      * The game you are trying to run (?) does not accept joystick input.
      * The “keyboard joystick” is inserted into the wrong Amiga port, or the joystick port is not in “joystick mode”.

      What game are you trying to run? Does the arrow keys properly emulate the joystick directions? Have you tried another game?

      • I have tried different games and the result is the same: the arrows work fine, but the fire key(s) not! Settings: FS-UAE-Launcher –> Input Options –> Joystick & Mouse Port: first option: left = Joystick, right = Default (Keyboard).

        • Hmm, right now the only ideas which comes to mind are:
          * Some utility has been used to re-map the keys on your keyboard somehow (so that right alt is no longer a right alt key for example) (?)
          * A non-standard keyboard is used with OS X (?)
          * … (*)

          It is possible to debug this (log to log file what keycodes are issued when keys are pressed inside FS-UAE), but it is a bit cumbersome to do.

          There is an option in FS-UAE Launcher settings to swap the left and right ctrl keys. Have you tried this? If you enable this option, left ctrl will be used as fire button.

          • Ok, I found some sort of a solution! 🙂

            Your phrase “There is an option in FS-UAE Launcher settings to swap the left and right ctrl keys” was helpful: I tried it, and I noticed that now both Ctrl keys were “fire”!

            After many tries, I found what is going on:

            1) Without the “swap the left and right ctrl keys” option enabled, I must press both Ctrl (or both Alt) buttons to get “fire”!
            2) With the “swap the left and right ctrl keys” option enabled, I can simply press: a) only left Ctrl, or b) only right Ctrl, or c) both left+right Alt keys, to get “fire”!

            Thank you for your help! 🙂

  4. Pingback: FS-UAE: Emulador de Amiga | Cógeme la matrícula

  5. For OS X users you can do the following to have F-Keys function as standard:

    1) Set function keys to work as normal by going to:
    System Preferences > Keyboard > and check the box in front of “Use all F1, F2, etc. keys as standard function keys”

    2) Remove “F-Key” shortcuts from Mission Control by going to:
    System Preferences > Mission Control and remove shortcut keys under section “Keyboard and Mouse Shortcuts”

    • Thanks for providing this information for other users 🙂 (I have done this myself actually!)

    • This doesn’t help in my case. I’ve tried with several different languages for keyboard as well. fn+Cmd does not work either. This is kind of a major issue, as I cant toggle between disks in game.

      • I’m not sure what could be wrong. F12 should be F12, at least if you have changed the OS X settings (and that not some other system utility has re-mapped the F12 key in any way, if that is possible).

  6. Hi. I’m a Mac user with an iMac with OS X 10.10 onboard and I’m trying to solve a problem: my OS intercepts the special key F12 both in window and full screen mode so I’m not able to use the keyboard shortcuts. I also tried to use F12 in combination with the Cmd key but nothing changed.

    (Moreover, it intercepts any special combination of keys if this mapped on OS X, i.e. I cannot use the right-Ctrl to emulate the fire button because if I press it in conjunction with the left cursor key, I go to the second desktop :-), so I have to use the right-Alt key.)

    • Hi, these are known issue (which I cannot do anything about, as far as I know). You can just use the right alt key as fire, and as for the F12 key, you can either disable the use of F12 as a shortcut key in OS X, or you can combine F12 with the Cmd key (Cmd+F12) to prevent OS X from intercepting it (http://fs-uae.net/keyboard-shortcuts).

  7. Hi, i am using an old amiga 600 with a keyrah and it works like an ordinary keyboard. The issue is that there is no F12 and i tried to put this in the custom configuration:

    keyboard_key_f10 = action_key_f12

    It does not work and i can see that there is no action key more than f10 as the amiga doesnt have one.

    Is there any other way to use f12 on an amiga keyboard?

  8. Great software, Frode -thank you very much! Just two notes:

    – Is it possible to prevent the emulator from exiting the emulation by pressing rcommand+q? (MacBookPro)
    This is unfortunately the Quit-key for SE on Amiga (and many other editors/tools)?

    – There also is a problem with the trackpad calibration – switching through fullscreen applications with ctrl+cursor left/right leaves FS-UAE in a somehow “decalibrated” state and I cannot move the mousepointer across the whole screen anymore (usually the upper 20% are unreachable). If I stay inside FS-UAE and do not switch workspaces, everything is fine. I’m running in RTG mode.

  9. What if you need one of the keys to go into the emulator instead of do the shortcut? For example, many of the games are configured to use PrtScr to exit WHDLoad, but PrtScr takes a screenshot.

  10. Why is the screenshot saved to the desktop? I’d much rather be able to set a directory to save screenshots in.

Leave a Reply

Your email address will not be published. Required fields are marked *