Keyboard Input

Not all Amiga keys are present on modern computer keyboards, and vice versa. Most keys are mapped like you would expect (F1 on your keyboard activates F1 on the emulated Amiga keyboard, etc).

Here are some notable exceptions:

  • Amiga Help = End (Mac laptops: Fn + Right)
  • Amiga Delete = Delete (Mac laptops: Fn + Backspace)
  • Amiga Numpad Left Paren = Home (Mac laptops: Fn + Left)
  • Amiga Numpad Right Paren = Page Up (Mac laptops: Fn + Up)
  • Amiga Left A = Page Down or Right Menu / Right Windows key.
  • Amiga Right A = Left Menu / Left Windows key.
  • Amiga Ctrl = Left Ctrl
  • Amiga key to the left of Backspace = Insert

Emulator keyboard shortcuts are documented on a separate page.

Key Mapping and International Keys

International keys are positionally mapped as best as possible, which hopefully means that you can set your keyboard layout in Amiga Workbench and the keyboard behaves like it is supposed to. This means that symbols on your PC keyboard (and modifier keys) will not correspond to what is input on the Amiga – unless a PC-compatible keyboard map is installed.

Emulating a Joystick or Gamepad via the Keyboard

When you emulate an Amiga joystick with your keyboard, the following keys are used to control the joystick:

  • Cursor keys controls the joystick stick.
  • Right Ctrl or Right Alt controls the fire button.

When the keys are used to emulate the joystick, they will not activate the corresponding Amiga keys while you use this feature. So to use all Amiga features at the same time, a connected real joystick or gamepad is recommended, though it is usually not a problem. Most joystick-controlled games do not require the keyboard cursor keys to be used also…

When playing CD32 games with the keyboard emulating a gamepad, additional keys are used to control the addition buttons on the gamepad:

  • Cursor Keys – Controls the directional pad.
  • C – Red
  • X – Blue
  • D – Green
  • S – Yellow
  • Return – Play
  • Z – Rewind
  • A – Forward
  • Right Ctrl or Right Alt also controls the red button.

Emulating a Second Joystick with Keyboard

FS-UAE does not support two emulated joysticks on one keyboard out of the box. But it is still possible to do it πŸ™‚

If you want to map keys on the numpad to the Amiga joystick in the mouse port, you can put something like this in advanced settings:

keyboard_key_kp4 = action_joy_0_left
keyboard_key_kp6 = action_joy_0_right
keyboard_key_kp8 = action_joy_0_up
keyboard_key_kp2 = action_joy_0_down
keyboard_key_kp0 = action_joy_0_fire_button

You’ll then specify Joystick as mode for the mouse port, and select No Host Device. The above settings will make sure the keys are mapped regardless!

49 thoughts on “Keyboard Input

  1. Hi, is there something I don’t remember, or is there something weird going on? I’m finnish user and need to use at least swedish keyboard, but I’m unable to get it done? What should I do to get swedish keyboard in use? I use Linux-version of fs-uae. BTW it’s very nice piece of software. Only this problem I haven’t found solution from Google.

    • You need to change the keyboard layout using *Workbench*, like you would on a real Amiga. The symbols won’t necessary match your host keyboard though. It will work (more or less) as if you had an “overlay” of a real Swedish Amiga keyboard on top of your real keyboard.

  2. Hi Frode, was playing battle squadron with a friend, but I can’t see any configurations for any “special button” only the fire button. But works fine on the mouse such as right mouse button. I also read a gamepad is recommended πŸ˜€ Maybe works on a gamepad?

    Best Regards:

  3. Hi, I noticed today, that at least the last dev release 2.7.7 mixed up some keypress combinations. With the stable 2.6.2 release I used to
    switch Workbench Screen in OS3.9 with left amiga + m or left amiga + n (on my Macbook Pro 2015 cmd+m, cmd+n).
    With 2.7.7 i cant do this anymore, instead disk drive volume an sound volume is toggled with this.

    How can I change this back to the 2.6.2 behaviour again? I hope the next stable release will not have this issue.

    Thanks for your great work.


    • Hi, the Cmd key (Alt on Windows/Linux) has been changed to a “modifier” key only by default in recent dev versions. There are reasons for this choice. However, you can disable the use of this modifier key by pressing Cmd+K (enables “full keyboard emulation”). You can also put full_keyboard = 1 in FS-UAE Launcher – Advanced Settings – if you want start FS-UAE in this mode.

  4. Is the Amiga Help key hard coded to “End”? No matter what I do, I can’t seem to get the Help key remapped. I want it mapped to my keyboard’s Help key. (yes, I have an actual Help key on my keyboard)

    • Hi, if you use the latest dev version, then you can:
      – enable logging of input events in FS-UAE Launcher
      – start FS-UAE and press your help key several times
      – quit FS-UAE, and send fs-uae.log.txt to frode@fs-uae-net

  5. Hi, found usability issue when simulating joystick using keyboard on OSX. Ctrl+Left / Ctrl+Right accidentally switches between spaces (Screens). AFAIK this cannot be customized in OSX. Do you have any suggestions on how to map the Ctrl and Alt keys to custom keys to avoid this to happen?

  6. I have just _installed_ this to my Macbook Pro, 13 inch, circa August 2012, UK keyboard layout, OSX 10.7.5.
    Can someone tell me where the ASCII characters ‘\’ and ‘|’ are mapped to?
    (That is the backslash and pipe characters.)

    The ‘~’ ‘`’, (tilde and backtick characters), are remapped OK to the key below the Esc key but I cannot get at the other two no matter how I try.

    IF I connect a random external USB keyboard I can find these two characters mapped to the INSERT key.

    The emulator runs ADPro 2.5 admirably and ADE, UNIX gcc suite, seems good to, as does ACE Basic compiler…

    Apart from this KB mapping problem it is an excellent alternative to WinUAE…

    • Hi, please see the following thread for more information about this (and especially check the bottom post for a specific suggestion).

      (Btw, there is also probably a Fn-combination on your Macbook which triggers the “Insert” key).

    • As of 2.5.34dev, keyboard_key_backslash is mapped to action_key_backslash by default. The host insert key is mapped to Amiga keycode 0x2B (was previously on the “backslash key”).

  7. Hi. I’ve increased the key repeat speed in WB, but after around 20 repeats the tempo slows down (to normal speed, 100, it seams). This doesn’t happen in WinUAE, only in FS. Is there a setting for this or is this only ony my OSX FS-UAE?

    • Nevermind. Running the exact same (shared on dropbox) launcher & fs-uae on another Mac (Pro) and everything is fine. Now I’ll have to find out why it’s slowing down on my new Macbook.

      • It sounds like it could be a key repeat problem of some kind. I mean, if FS-UAE gets information from the host operating system (OS X) that the key is repeatedly pressed and released, then that would control the speed. So I’m guessing the Workbench key repeat works fine while the host key is pressed, and then when the host starts key-repeating, it “stops working”. FS-UAE tries to disable host key repeat when it starts, perhaps it does not work on one of your computer for some reason… (I haven’t heard about the problem before).

        • Thanks for tip. Don’t know why I didn’t test that. It has to do with the key repeat settings in OSX. If I slow down key repeat in OSX all kind of weird things happen in FS, even interval speed :D. To get normal behavior I have to turn off key repeat in OSX. I guess OSX have a different (weird) way to send key repeat messages to apps than Win & Linux? I can at least confirm this behavior on 2 differrent OSX versions (Mavericks & Yosemite). Only usable settings is to have Key Repeat at either off (best) or the fastest (usable) setting. Now I know how to get normal Amiga behavior at least. Makes a world of different in AsmOne. Thanks! πŸ™‚

          • Hmm, I have found a potential keyboard repeat fix, but since I have not been enable experience the problem – not on OS X either, I’m not sure. This could also be the same issue:

            I’ll provide a new development release later this evening. Please test 2.5.35dev when it is released, and see if the problem goes away *without* disabling key repeat in OS X.

  8. Hi, is there a way for FS-UAE to detect if 2 gamepad controllers are connected, and automatically assign them to joystick ports? As opposed to having to go into the menu and assigning the second joystick to a port? Cheers

    • Yes, FS-UAE will “auto-fill” all Amiga joystick ports with available gamepad devices. So all you need to do is to set:
      joystick_port_0_mode = joystick
      (so the Amiga “mouse port” is configured as a joystick port)

  9. Hi! I’m running FS-UAE by starting FS-UAE Launcher 2.4.1. It works fine, but the arrow key does not responds at all! In AmigaShell I cant press arrow-up to get last command, and in applications I cant move around the cursor by the arrow keys. Any ideas?
    (Later edit: I have solved the problem. It was some default joystick setting I could remove and then it worked!)

  10. Hi, I’m having this problem with one particular game (Captive), when I press a key (eg. to move) it always gives me at least a double key press. If I hold the key down then it rapidly presses the key repeatedly. The mouse is fine. This behaviour also occurs when typing names, etc.
    I also play Dungeon Master which runs perfectly.

    Please help?

    • Hi, are you using the online game database, or have you created a configuration for the game manually? If the latter, can you send the configuration file (.fs-uae) to

Leave a Reply to Alex Power Cancel reply

Your email address will not be published. Required fields are marked *

This site uses Akismet to reduce spam. Learn how your comment data is processed.